Cab light in my 90 doesn't work

This is for "general" electrical discussions. Audio, security, remote start, and power accessories should go here, since they don't seem to fit anywhere else. Not for diesel-specific (like glow systems), or gasoline-specific (like ignition systems) topics.
Xeno227
Regular Member
Posts: 5
Joined: Fri Jan 18, 2019 12:09 pm
Location: Wyoming
Isuzu vehicle(s): 1990 pickup 2.3l 5 speed RWD

Cab light in my 90 doesn't work

Postby Xeno227 » Tue Sep 03, 2019 10:03 pm

So, I've been trying to fix the cab light in old blue, and I can't seem to get it to work, it worked for about 2 months back in November, then it quit working all together,I've changed the entire cab light assembly and still no dice, do you guys have any ideas what it could be?

Darby
Regular Member
Posts: 401
Joined: Tue Jun 19, 2012 5:36 pm
Location: Tampa Florida

Re: Cab light in my 90 doesn't work

Postby Darby » Wed Sep 04, 2019 12:05 pm

The bulb or the fuse. It's a 10 amp.
Original owner of a 1993 Isuzu pick up, 2.3 engine, 5 speed with power steering and air conditioning. All original except the radio (still have factory radio).
It's cheaper to fix what you have than to buy someone else's problems.

Xeno227
Regular Member
Posts: 5
Joined: Fri Jan 18, 2019 12:09 pm
Location: Wyoming
Isuzu vehicle(s): 1990 pickup 2.3l 5 speed RWD

Re: Cab light in my 90 doesn't work

Postby Xeno227 » Wed Sep 04, 2019 1:29 pm

With the fuse, my grandpa put an aftermarket stereo in and wired it into that fuse so it's a 15, would rewiring the stereo to a different fuse or a blank in my panel possibly fix it?