Running rich

The place to discuss problems and routine maintenance questions and tips that are NOT specifically diesel-related.
ridinfatdownsth
Regular Member
Posts: 3
Joined: Wed Aug 22, 2018 4:11 pm
Location: GA
Isuzu vehicle(s): 1993 isuzu pick up 2.3l

Running rich

Postby ridinfatdownsth » Wed Aug 22, 2018 5:17 pm

I have a 93 pickup with the 2.3 l engine. I’m having an issue when I start my truck it’s running real rich and fuel is coming out of the Excelerator pump on the carb. I recently bought this pickup without a motor. I put an engine from a 91 pickup in it and am trying to figure out what may be causing this. I tried a different factory carb and it does the same exact thing. Is this a common problem with these carbs? Is this something I can fix? I am running the mechanical fuel pump which is new. Any help would be greatly appreciated. Thanks!

oldestisuzuist
Regular Member
Posts: 1318
Joined: Tue Oct 07, 2008 9:10 pm
Location: N W Arkansas

Re: Running rich

Postby oldestisuzuist » Wed Aug 22, 2018 8:47 pm

Sounds like your float level may need adjusted. Some 2.3 carbs have a float bowl fuel level sight gauge on the front of the carb, if yours does the fuel level should be centered on the circle in the sight gauge. adjust by bending the stop tab on the float.
Also make sure the fuel return from the mechanical pump is hooked up & functioning.
'78 Chevy LUV,1.9,4sp,headers,31's,SAS Dana 30,Dana 20,SOA rear w/Aussie Locker, body ROUGH, bought new 12/4/78. A pre-P'up?
'87 Trooper,2.3,5sp,headers,31's,ball joint flip & spacer,Aussie Locker rear,Superwinch hubs,brush guard w/5.5K winch.

ridinfatdownsth
Regular Member
Posts: 3
Joined: Wed Aug 22, 2018 4:11 pm
Location: GA
Isuzu vehicle(s): 1993 isuzu pick up 2.3l

Re: Running rich

Postby ridinfatdownsth » Thu Aug 23, 2018 12:34 pm

I’m just a tad bit over half way on the site glass. What is the best way to test and make sure the return is working properly?