Thermostat not functioning properly

The place to discuss problems and routine maintenance questions and tips. This is for topics that are specifically diesel-related.
cwill
Regular Member
Posts: 59
Joined: Sun Nov 26, 2006 10:35 pm
Location: Northern CA

Thermostat not functioning properly

Postby cwill » Sun Jul 08, 2018 7:02 pm

My thermostat does not seem to open and stay open properly. I thought it went bad and replaced it with a new one, but am getting the same problem. It takes too long and gets too hot before it opens. It then seems to be fine,especially at hwy speeds. But, if I stop the engine and resume driving again in the very near future, with coolant temp still plenty warm, the temp. again goes too high before the thermostat apparently opens again and the temp. drops again. I thought the thermostat opened and closed by coolant temp. only. What am I missing?
82 Chevy Luv
2.2 Dsl
4spd & 4wd

cwill
Regular Member
Posts: 59
Joined: Sun Nov 26, 2006 10:35 pm
Location: Northern CA

Re: Thermostat not functioning properly

Postby cwill » Sun Jul 08, 2018 10:30 pm

As a postscript, the radiator is new, less than 600 miles, and the water pump is newer,less than 200 miles. This problem happened just recently and acutely.
82 Chevy Luv
2.2 Dsl
4spd & 4wd

User avatar
puttputtinpup
Regular Member
Posts: 10214
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Thermostat not functioning properly

Postby puttputtinpup » Mon Jul 09, 2018 7:15 am

This may sound like a stupid question. Is the thermostat installed correctly? Is it the right one? 81,82(maybe83) used a different style than the rest. Did the thermostat have a little jiggler in it? Lets bubbles through. What temp is it? 180, 190something?
The inline oil cooler thermostat may be clogged. According to Jerry Lemond, its okay to remove those if not working right.
The oil cooler under the filter could be restricted with sludge and rust.
Or, maybe the temp sensor (located on lower thermostat housing on passenger side, not one of the 2 in the thermostat cover) may not be responding accurately

cwill
Regular Member
Posts: 59
Joined: Sun Nov 26, 2006 10:35 pm
Location: Northern CA

Re: Thermostat not functioning properly

Postby cwill » Wed Jul 11, 2018 11:19 am

I got it at Napa for the '82 Isuzu Pup 2.2 litre diesel. It had that little bubbler. It was installed correctly. It was the 180F type. Temp sensor working well.
82 Chevy Luv
2.2 Dsl
4spd & 4wd

2sk8
Regular Member
Posts: 196
Joined: Thu Apr 17, 2008 2:59 am
Location: California
Isuzu vehicle(s): 91 Isuzu Pick up converted to diesel

Re: Thermostat not functioning properly

Postby 2sk8 » Wed Jul 11, 2018 12:21 pm

Where is the inline oil cooler thermostat?

User avatar
puttputtinpup
Regular Member
Posts: 10214
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Thermostat not functioning properly

Postby puttputtinpup » Wed Jul 11, 2018 2:21 pm

2sk8 wrote:Where is the inline oil cooler thermostat?

Its bolted to the head at the rear in a bracket. Follow the heater hose from the heater core hose and down to the oil cooler/filter.


Return to “Diesel - Troubleshooting and Maintenance”

Who is online

Users browsing this forum: No registered users and 5 guests