Help, no headlights or running lights...

The place to discuss problems and routine maintenance questions and tips that are NOT specifically diesel-related.
User avatar
davidgrace
Regular Member
Posts: 51
Joined: Mon May 25, 2020 9:00 pm
Location: NM
Isuzu vehicle(s): 1986 P'up Spacecab w/ 1986 Trooper II diesel engine project 1982 P'up diesel, 5 speed short bed

Help, no headlights or running lights...

Postby davidgrace » Sat Jun 27, 2020 11:26 pm

Hi all,

I'm having an issue with my FrankenP'up!

86 Gasser with an 86 trooper turbo diesel and a 1981 L'uv wiring harness.
The headlights, running lights, dash lights, etc. will not turn on. There is nothing wrong with the switch, there is power going to the switch, but nothing happens when I pull the switch on! If I pull the brights switch on the steering column the brights do turn on.
Are there fusible links somewhere that need to be replaced???
I'm at a loss at this point.


Thank you!
David

User avatar
davidgrace
Regular Member
Posts: 51
Joined: Mon May 25, 2020 9:00 pm
Location: NM
Isuzu vehicle(s): 1986 P'up Spacecab w/ 1986 Trooper II diesel engine project 1982 P'up diesel, 5 speed short bed

Re: Help, no headlights or running lights...

Postby davidgrace » Sun Jun 28, 2020 3:22 am

Update—-
I got the running lights and dash lights going by jiggling fuses

User avatar
puttputtinpup
Regular Member
Posts: 10649
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Help, no headlights or running lights...

Postby puttputtinpup » Sun Jun 28, 2020 9:03 am

davidgrace wrote:Update—-
I got the running lights and dash lights going by jiggling fuses

Great! Sometimes the combination switch on the column goes bad. That was my 1st thought.

User avatar
Halden
Regular Member
Posts: 2880
Joined: Thu Mar 29, 2012 5:20 pm
Location: Everertt, WA
Isuzu vehicle(s): 83 Dsl LS Long Bed 4x4, 82 Dsl 2wd Short Bed 5 spd

Re: Help, no headlights or running lights...

Postby Halden » Sun Jun 28, 2020 11:22 am

davidgrace wrote:Update—-
I got the running lights and dash lights going by jiggling fuses


Fuses are always the first things to look at. And if they check good give a wiggle around there and spray some contact cleaner in there. :D
It's not pronounced "Ih-soo-zoo", it's pronounced "It-screws-you"
83 LS Long Box Dsl 4x4
82 Short Box Dsl 5 spd
64 Chevy C20 w/ 283 & 4 speed.
05 Sonata with a standard

User avatar
davidgrace
Regular Member
Posts: 51
Joined: Mon May 25, 2020 9:00 pm
Location: NM
Isuzu vehicle(s): 1986 P'up Spacecab w/ 1986 Trooper II diesel engine project 1982 P'up diesel, 5 speed short bed

Re: Help, no headlights or running lights...

Postby davidgrace » Sun Jun 28, 2020 12:47 pm

puttputtinpup wrote:
davidgrace wrote:Update—-
I got the running lights and dash lights going by jiggling fuses

Great! Sometimes the combination switch on the column goes bad. That was my 1st thought.


I opened up the switch last night, everything looked good in there. I also checked if there was power getting to the headlights in case they both had a bad low beam. No power at the lights

User avatar
Red Truck
Regular Member
Posts: 95
Joined: Wed Sep 18, 2013 7:10 pm
Location: Vader, WA

Re: Help, no headlights or running lights...

Postby Red Truck » Sun Jun 28, 2020 11:19 pm

'87 Isuzu p'up 2.3 gas, 5spd, 4WD, base model, Fed spec

User avatar
davidgrace
Regular Member
Posts: 51
Joined: Mon May 25, 2020 9:00 pm
Location: NM
Isuzu vehicle(s): 1986 P'up Spacecab w/ 1986 Trooper II diesel engine project 1982 P'up diesel, 5 speed short bed

Re: Help, no headlights or running lights...

Postby davidgrace » Mon Jun 29, 2020 12:46 am

Okay, so the circuit breaker under the dash is good.
I tried switching out for another dimmer switch that I had available and still nothing.
I do have bright lights, when I pull back the lever the brights turn on and back off when I release. If I push forward the brights come on and stay on...
Could it be that both dimmer switches I have are bad??
Is it because the wiring harness is from and 81 and my dimmer switches are both from and 86?

User avatar
puttputtinpup
Regular Member
Posts: 10649
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Help, no headlights or running lights...

Postby puttputtinpup » Mon Jun 29, 2020 5:29 am

I'm not sure about the headlight circuit 81 vs 86 but at one time I assumed the combo sw with delay wilers off a trooper would plug & play with the harness on my 82. It didn't work. The issues I noticed were 4way and turn signals didn't work right. It could have been that the headlights didn't work either. I yanked out the trooper combo sw and put my original back in. Fyi, the trooper combo sw harness with delay wipers has a green plastic plug. If under your dash harness is off the trooper, use the combo sw from it and see what happens

User avatar
davidgrace
Regular Member
Posts: 51
Joined: Mon May 25, 2020 9:00 pm
Location: NM
Isuzu vehicle(s): 1986 P'up Spacecab w/ 1986 Trooper II diesel engine project 1982 P'up diesel, 5 speed short bed

Re: Help, no headlights or running lights...

Postby davidgrace » Thu Jul 02, 2020 8:00 pm

Well.. at some point in my tinkering around I managed to get power to my head lights (I suspect a dirty contact point in my dimmer switch). After re-checking to see if power was getting to my headlights, which it was, I had a secondary issue of 2 dead head lights! What a pain...

On to the next issue....