'85 pup climate control

This is for "general" electrical discussions. Audio, security, remote start, and power accessories should go here, since they don't seem to fit anywhere else. Not for diesel-specific (like glow systems), or gasoline-specific (like ignition systems) topics.
mbiggerstaff
Regular Member
Posts: 8
Joined: Fri Jul 14, 2017 7:26 pm
Location: Greenville, NC
Isuzu vehicle(s): 1985 pup diesel 5 speed

'85 pup climate control

Postby mbiggerstaff » Sat Jul 15, 2017 7:59 am

Trying to get my pup back on the road. It has been sitting at my dad's house for years. Got the body and mechanical work done now starting on inside. The little truck has AC which was installed by the dealer. The problem is that I have no power to the climate control. The AC clutch will not engage(new compressor which I tested) and the fan will not run. Where do I start. All fuses replaced already.

User avatar
JoeIsuzu
Site Admin
Posts: 19927
Joined: Thu Aug 19, 2004 9:11 am
Location: Germantown (next to Elvistown), TN
Isuzu vehicle(s): Original owner, '83 LS Diesel, 5-spd, 2wd, Long Bed, restoration in progress!

Re: '85 pup climate control

Postby JoeIsuzu » Sat Jul 15, 2017 8:32 am

Verify that your charge relay is working.

Jack

User avatar
puttputtinpup
Regular Member
Posts: 10120
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: '85 pup climate control

Postby puttputtinpup » Sat Jul 15, 2017 11:58 am

I'm pretty sure it's the little blue one on the driver's side inner fender. If it senses the alternator is charging okay, it clicks on and allows 12v to other circuits like blower fan, etc
Currently P'up-less, but keeping my eyes open for a good deal
Click this link for misc. diesel technical bulletins & other info

mbiggerstaff
Regular Member
Posts: 8
Joined: Fri Jul 14, 2017 7:26 pm
Location: Greenville, NC
Isuzu vehicle(s): 1985 pup diesel 5 speed

Re: '85 pup climate control

Postby mbiggerstaff » Mon Jul 17, 2017 1:38 pm

Ok. I replaced the charging relay, took every connection under the hood apart, cleaned and applied dielectric grease, bought a new 4 and 5 pin relay and alternated them thru all the ones under the dash,(2 on the heater core box and one over near the fan). Still no power. Whats next? I know the fan and compressor work.

User avatar
JoeIsuzu
Site Admin
Posts: 19927
Joined: Thu Aug 19, 2004 9:11 am
Location: Germantown (next to Elvistown), TN
Isuzu vehicle(s): Original owner, '83 LS Diesel, 5-spd, 2wd, Long Bed, restoration in progress!

Re: '85 pup climate control

Postby JoeIsuzu » Mon Jul 17, 2017 2:29 pm

Get out the multimeter and start tracing the circuit. But I'd start at the relay, just because it's easy. You will need to do it with the engine running.

Jack


Return to “Electrical Troubleshooting, Maintenance, and Upgrades”

Who is online

Users browsing this forum: No registered users and 1 guest