Ventilation blower won't run

The place to discuss problems and routine maintenance questions and tips that are NOT specifically diesel-related.
aliciajae
Regular Member
Posts: 8
Joined: Thu Oct 05, 2017 3:01 am
Location: Idaho
Isuzu vehicle(s): 1995 Isuzu Pickup

Ventilation blower won't run

Postby aliciajae » Sat Oct 14, 2017 3:48 pm

On my 1995 Isuzu pickup I am not getting any air from the vents. I have checked the fuse, replaced the relay, replaced the blower motor, and replaced the resistor. I have power through the resistor and still nothing. Any suggestions or ideas for me?!? Thank you
Last edited by JoeIsuzu on Sat Oct 14, 2017 8:23 pm, edited 1 time in total.
Reason: Subject change (was "No air coming from vents")

aliciajae
Regular Member
Posts: 8
Joined: Thu Oct 05, 2017 3:01 am
Location: Idaho
Isuzu vehicle(s): 1995 Isuzu Pickup

No air coming from vents

Postby aliciajae » Sat Oct 14, 2017 4:04 pm

I have a 1995 Isuzu pickup with no air coming from the vents. I have checked the fuse, replaced the relay, replaced the blower motor and replaced the resistor. I have power through the resistor and still no air flow from vents. Any suggestions or ideas? Thnank you!

dorf
Regular Member
Posts: 345
Joined: Sun Jul 17, 2011 1:03 pm
Location: N. Central Arkansas 81 LUV 4x4

Re: No air coming from vents

Postby dorf » Sat Oct 14, 2017 4:08 pm

Sometimes my 81 does that ......no air no nothing........
until the alternator spins up .....to operating voltage....to activate the relay

I'm not familiar with a 95......but maybe a missing ground

aliciajae
Regular Member
Posts: 8
Joined: Thu Oct 05, 2017 3:01 am
Location: Idaho
Isuzu vehicle(s): 1995 Isuzu Pickup

Re: No air coming from vents

Postby aliciajae » Sat Oct 14, 2017 4:39 pm

Thanks for the reply. Is it possible that there could be a problem with the switch that controls the 4 speed settings?

dorf
Regular Member
Posts: 345
Joined: Sun Jul 17, 2011 1:03 pm
Location: N. Central Arkansas 81 LUV 4x4

Re: No air coming from vents

Postby dorf » Sat Oct 14, 2017 5:15 pm

I guess the best thing would be to start checking voltage to the switch then use a jumper as appropriate to make it function

Sorry can't be of more help

User avatar
JoeIsuzu
Site Admin
Posts: 20185
Joined: Thu Aug 19, 2004 9:11 am
Location: Germantown (next to Elvistown), TN
Isuzu vehicle(s): Original owner, '83 LS Diesel, 5-spd, 2wd, Long Bed, restoration in progress!

Re: No air coming from vents

Postby JoeIsuzu » Sat Oct 14, 2017 6:02 pm

Wait, are you saying the blower isn’t working? That’s a completely different issue from “No air coming from vents”.

Jack

aliciajae
Regular Member
Posts: 8
Joined: Thu Oct 05, 2017 3:01 am
Location: Idaho
Isuzu vehicle(s): 1995 Isuzu Pickup

Re: No air coming from vents

Postby aliciajae » Sat Oct 14, 2017 7:05 pm

So the blower motor has power but it is not spinning. This is a brand new blower motor. I basically have nothing happening with the heater/ac.

User avatar
JoeIsuzu
Site Admin
Posts: 20185
Joined: Thu Aug 19, 2004 9:11 am
Location: Germantown (next to Elvistown), TN
Isuzu vehicle(s): Original owner, '83 LS Diesel, 5-spd, 2wd, Long Bed, restoration in progress!

Re: No air coming from vents

Postby JoeIsuzu » Sat Oct 14, 2017 8:26 pm

aliciajae wrote:So the blower motor has power but it is not spinning. This is a brand new blower motor. I basically have nothing happening with the heater/ac.

Sounds like you may have replaced a perfectly good blower with a new one.

So is there current at the connector -- the last one that the blower connects to? If I recall correctly, it's a 2-wire connection rather one hot and a chassis ground. So be sure to ground your test lead via the wire, not directly to the body. You may have a bad ground.

Jack

aliciajae
Regular Member
Posts: 8
Joined: Thu Oct 05, 2017 3:01 am
Location: Idaho
Isuzu vehicle(s): 1995 Isuzu Pickup

Re: Ventilation blower won't run

Postby aliciajae » Sat Oct 14, 2017 8:59 pm

I also think I replaced a good working motor. I will check into your suggestion tomorrow. Thanks for the response.

User avatar
sanramonrover
Regular Member
Posts: 128
Joined: Fri Oct 11, 2013 11:58 am
Location: Canada & Costa Rica
Isuzu vehicle(s): 1991 KB (AKA TFS) 4X4 with 4JB1 Diesel

Re: Ventilation blower won't run

Postby sanramonrover » Sat Oct 14, 2017 9:47 pm

Since the motor has been replaced, here is a possibility - and it DID happen to me on a vehicle I bought.

Assuming the fan motor is spinning but no air comes out - the fan, being a centrifugal type fan, had been put on the shaft backwards! Yup, it tried to pull air from the same place it was trying to blow air out.
1991 KB 4X4
1988 VW Westfalia
1975 Triumph Spitfire