Stalls after starting warm

The place to discuss problems and routine maintenance questions and tips that are NOT specifically diesel-related.
User avatar
xomojo
Regular Member
Posts: 104
Joined: Sun Sep 21, 2008 3:24 pm
Location: Ocala Florida

Stalls after starting warm

Postby xomojo » Sun Feb 27, 2011 6:01 pm

Hello everyone,
95 2.3L FI.. Been somewhat trouble free for a bit but now when I drive somewhere and come back out my truck stalls out upon start up (once its warmed up).. I've found if I rev it right away it stops the stall out, otherwise it'll just keep doing it.. Its not making the check engine light come on so I can't self diagnose the problem.. Not sure what to check.. The truck is kept in tune and not neglected.. Good air filter, wires, plugs etc.. Somewhat recent O2 sensor, belts, hoses, timing belt, fuel pump, fuel filter... Once you get past the stall it runs without a hitch, like it always has.. Would like to fix the problem though, any ideas.?
Thanks, Joe
Green 95 Pickup 2.3L FI

User avatar
mckay105
Regular Member
Posts: 83
Joined: Thu Mar 10, 2011 7:33 am
Location: Quantico, VA

Re: Stalls after starting warm

Postby mckay105 » Thu May 26, 2011 10:58 am

Did you get this fixed? Mine will stall sometimes after it gets hot, as in I let it idle for a while and then drive it, it will try to stall vut if I keep my foot on the gas it will eventually catch up. I have had to pull to the side of the road before. If I let it cool it will strt right back up again and go with no problems. I ahve heard it could be the EGR valve but I am planning on getting the Weber and doing away with it so I havent replaced it yet.
94 2.3L Isuzu Pickup. Full exhaust Pacesetter ceramic header thrush muffler and 2" pipe, Weber 38, and a delta 272 caM. Super customized suspension, interior and everything else.

User avatar
xomojo
Regular Member
Posts: 104
Joined: Sun Sep 21, 2008 3:24 pm
Location: Ocala Florida

Re: Stalls after starting warm

Postby xomojo » Thu May 26, 2011 12:48 pm

not fixed yet.. but its hot out so my A/C's always on which 'fixes' the problem, the higher idle doesn't let it stall out for some reason.. And I have a new EGR valve on mine..
Green 95 Pickup 2.3L FI


Return to “General Troubleshooting and Maintenance”

Who is online

Users browsing this forum: No registered users and 3 guests