Alternator not charging on startup

The place to discuss problems and routine maintenance questions and tips. This is for topics that are specifically diesel-related.
User avatar
pup daddy
Regular Member
Posts: 352
Joined: Fri Apr 22, 2005 10:12 am
Location: Lancaster, SC

Alternator not charging on startup

Postby pup daddy » Wed Sep 14, 2011 8:17 am

Thy guy who rebuilt my alternator says that one of the small wires going to the alternator is supposed to energize it and make it start charging as soon as the engine starts. Now I have to rev the engine a little before it will start charging. He thought it was more trouble than it was worth to try to track down the cause, I'm hoping some pup genius already knows were I should start looking, lol.

thanks!
1985 Pup diesel 4x4 4spd SB (daily truck)
1986 Pup diesel 4x2 turbo LB (Waiting for some love)
1990 chevrolet 454SS pickup
1983 Mercedes 300sd

dorf
Regular Member
Posts: 368
Joined: Sun Jul 17, 2011 1:03 pm
Location: N. Central Arkansas 81 LUV 4x4

Re: Alternator not charging on startup

Postby dorf » Wed Sep 14, 2011 9:35 am

Tap the alternator( with a small hammer) briefly.I'll bet the brushes have not seated and are a little cocked in the housing.
Happened to me.. I removed and troubleshot the alternator....no problem existed. Your brushes are not making contact.

User avatar
puttputtinpup
Regular Member
Posts: 10660
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Alternator not charging on startup

Postby puttputtinpup » Wed Sep 14, 2011 3:56 pm

dorf wrote:Tap the alternator( with a small hammer) briefly.I'll bet the brushes have not seated and are a little cocked in the housing.
Happened to me.. I removed and troubleshot the alternator....no problem existed. Your brushes are not making contact.
dittos, or a bad charging relay on the fender. tap those also to see it it corrects the issue.