Alternator issue

The place to discuss problems and routine maintenance questions and tips. This is for topics that are specifically diesel-related.
82 luv
Regular Member
Posts: 11
Joined: Wed Dec 30, 2020 10:18 pm
Location: Mendocino
Isuzu vehicle(s): 1982 Chevy luv diesel

Alternator issue

Postby 82 luv » Sat Feb 20, 2021 5:03 pm

So I bought a new alternator for my my 82 Chevy luv and when trying to install it it doesn’t have a black plug like the new one I ordered. Would it be fine if I just hard wire them together or should I go prefer the plug for it? What would the plug part number be

User avatar
JoeIsuzu
Site Admin
Posts: 20638
Joined: Thu Aug 19, 2004 9:11 am
Location: Germantown (next to Elvistown), TN
Isuzu vehicle(s): Original owner, '83 LS Diesel, 5-spd, 2wd, Long Bed, restoration in progress!

Re: Alternator issue

Postby JoeIsuzu » Sat Feb 20, 2021 6:55 pm

I guess you traded the old one in? If not, I'd see about swapping the connector.

Jack

82 luv
Regular Member
Posts: 11
Joined: Wed Dec 30, 2020 10:18 pm
Location: Mendocino
Isuzu vehicle(s): 1982 Chevy luv diesel

Re: Alternator issue

Postby 82 luv » Sat Feb 20, 2021 7:50 pm

I haven’t traded my old one in yet I still have it but can’t figure out where the wire exactly goes and if there is a connector for my old one. It’s the black one
Attachments
B5AE6313-6ACE-455D-929C-2799E7134BB6.jpeg

User avatar
puttputtinpup
Regular Member
Posts: 10951
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Alternator issue

Postby puttputtinpup » Sun Feb 21, 2021 4:16 am

Doesn't your new one have the white plug also like in the picture?

82 luv
Regular Member
Posts: 11
Joined: Wed Dec 30, 2020 10:18 pm
Location: Mendocino
Isuzu vehicle(s): 1982 Chevy luv diesel

Re: Alternator issue

Postby 82 luv » Sun Feb 21, 2021 12:46 pm

Yes it has the white one on it and so does the truck it’s the black one the truck doesn’t have

User avatar
puttputtinpup
Regular Member
Posts: 10951
Joined: Sat Oct 08, 2005 5:18 am
Location: Winston Salem, NC

Re: Alternator issue

Postby puttputtinpup » Sun Feb 21, 2021 1:31 pm

It may be for another application. I don't have my truck anymore so I can't double-check mine. Paul might know. I'd hook it up with the white plug and see if it works. Some NPR trucks had a very similar alternator and that black plug may be for something on those engines.

User avatar
Paul
Regular Member
Posts: 1221
Joined: Thu Nov 25, 2004 11:14 pm
Location: Central Calif Coast

Re: Alternator issue

Postby Paul » Mon Feb 22, 2021 12:37 am

That black connector has what looks like a heavy black wire feeding it. Makes me think that it is the 'B' lead connector. Also, it comes from the side of the alternator where the 'B' lead post normally is located.

The 'B' lead is the alternator output, normally connected to the battery.

Paul
'84 P'UP 2 wd diesel, 5 spd with 0.78 fifth gear and differential back to 3.73.

User avatar
Halden
Regular Member
Posts: 2927
Joined: Thu Mar 29, 2012 5:20 pm
Location: Everertt, WA
Isuzu vehicle(s): 83 Dsl LS Long Bed 4x4, 82 Dsl 2wd Short Bed 5 spd

Re: Alternator issue

Postby Halden » Mon Feb 22, 2021 9:03 pm

Just remove that black wire from it's post and connect it with the ring terminal already on the truck.
It's not pronounced "Ih-soo-zoo", it's pronounced "It-screws-you"
83 LS Long Box Dsl 4x4
82 Short Box Dsl 5 spd
64 Chevy C20 w/ 283 & 4 speed.
05 Sonata with a standard

User avatar
VEGGIE NATE
Regular Member
Posts: 590
Joined: Sat Jun 25, 2005 11:40 pm
Location: Bow WA

Re: Alternator issue

Postby VEGGIE NATE » Sun Feb 28, 2021 2:06 pm

I guessing with the previous couple of replies you have probably sorted out the confusion with the different wire. I’ll just add that replacing the brushes in the original alternator would be a cheap and viable option to be up and running again.
nate
1986 P'UP LWB,2WD,N/A,5-SPEED,3.42,WVO TWO-TANK